The steps below outline ways to improve the connectivity of the USBPre 2.

1. Verify Power. Connect the USBPre 2 to the computer.

When the USB cable is attached to the computer and the USBPre 2, the USBPre 2 meters should "dance" (illuminate back and forth in sequence). Pushing buttons on the front panel (Input Source Select buttons, PRE/PC button, and HP MONO button) should cause the respective LED's to illuminate or turn off.

If there is a problem at this stage:

  • Try another USB cable.
  • Try another USB port. It is recommended to perform all troubleshooting with an onboard USB port. External hubs and drive slot USB modules can pose problems, it is best to eliminate these factors at this stage.
  • Remove other USB devices to rule out any conflict.
  • Close any software application that is not relevant to the USBPre 2 during the troubleshooting stage. Applications that are designed to interact with other USB devices can sometimes cause conflicts with the USBPre 2.

2. Verify Installation.

Mac: Verify that the USBPre 2 can be viewed as a device in the Audio Midi Setup. The available sample rates should be 8 kHz, 16 kHz, 24 kHz, 32 kHz, 44.1 kHz, 48 kHz, 88.2 kHz, 176.4 kHz, and 192 kHz for 2 channels at 16- or 24-bit for both Input and Output.

Windows: Verify the USBPre 2 shows up as an audio device for both Playback and Recording. The available settings should be 2 channels, 16 bit with sampling rates of 8 kHz, 16 kHz, 32 kHz, 44.1 kHz, 48 kHz and 2 channels, 24 bit with sampling rates of 44.1 kHz and 48 kHz.

Linux: Supports USB Full Speed only. Press and hold Input 1 Source Select button while connecting the USBPre 2 to Linux systems.

If there is a problem at this stage:

  • Try another USB Cable and/or Port.
  • Check to make sure that no buttons were depressed at time of initial USB connection. If the PRE/PC button was stuck the USBPre 2 would always boot up in stand alone mode, if the Input 1 button was stuck the USBPre 2 would boot up in Full Speed mode.
  • If Linux doesn't see the USBPre 2 as a Playback device, then the USBPre 2 is not in Full USB Mode. Disconnect, press and hold Input 1 and reconnect the USBPre 2 to the computer.
  • USBPre 2 firmware version 1.0 has a bug in which the USBPre 2 doesn't show as a Playback device when in Full Speed USB Mode. Update USBPre 2 firmware.

3. Verify audio is clean.

  • Noisy audio.
  • Choppy audio (signal cuts in and out rapidly)
  • Audio is not at normal speed
  • Audio dropouts occur
  • Latency

If any of the above problems occur, verify the following:

  • Check the USB cable and port. Bad USB cables have been known to induce noise into the USBPre 2 signal path.
  • Verify that the USBPre 2, Audio MIDI Setup or Control Panel Sound hardware preferences, and the audio application are all set to the same sample rate. If a digital signal is sent to the USBPre 2, verify that it also is set to the same sample rate (even if it is not the currently selected input source).
  • Verify the computer's playback or recording stream was stopped during the time of initial connection. Issues have been observed when the USBPre 2 is connected while the operating system is actively streaming audio. Note that some applications will stream audio constantly while they are open, even if the signal consists of silence. Close all applications and reconnect the USBPre 2.
  • If using an external clocking source, ensure that the source was connected to the USBPre 2 at time that the USBPre 2 was connected to the computer via USB. Also make sure that the source is sending valid stable clock and the cable is good condition.
  • All applications running audio are running at the same sample rate (Mac).
  • If audio dropouts occur when using Windows Vista make sure that the MME driver is not being used. The MME driver has a bug in which samples are inserted into the playback stream. It has been confirmed that this occurs on other class compliant USB audio interfaces. Try using the DirectSound Driver.
  • Any bug reported should be verified using another application. Audacity is a great application for free but it does not come without it's own issues.
  • If experiencing latency issues, make adjustments to the application buffers.
  • If ¬†audio inputs are set to SPDIF but a valid signal is not detected, clocking issues can occur. The USBPre 2 may need to be reconnected.