Q: I have an early 744T, 722, 702T, or 702 recorder which has not yet been factory-updated with "2.0-ready" updates. Can I run firmware revisions later than 1.74 on it?

A: All 7-Series recorders, whether they have been updated to be "2.0-ready" or not can run 2.0 firmware update. The only feature that requires 2.0-ready hardware is external FireWire drive support. If the unit has not been updated, there is no option to record or transfer files to attached, external FireWire drives.

All other features will operate as documented.